Calorie Count
Moderators: popthestack, Igor

We just updated the Recipe Analyzer. The major innovation is the ability to use custom foods as ingredients.

We also tried to simplify the process of correcting unrecognized ingredients (try to mistype the serving size or ingredient name to see how we handle those cases).

It's clear to us that we still have to work on the following issues below, which will be corrected over the next couple of days:

  • Ingredients will link to their nutrition label pages
  • Easier process of linking recognized ingredients to a different food item
  • Better print layout

Please let us know if you have any other suggestions or feedback.

Edited Oct 07 2011 03:50 by Igor
247 Replies (last)

I just tried it again and get errors.  When I try to correct the errors it lists the foods but doesn't add the calories into the recipe.  I am also getting odd answers such as one cup of brown rice cooked is 688 calories?  I could use the old method to add many recipes, however I just can't figure this out.

I find that once I have entered a recipe that the amount of the individual ingredients weight is increased in proportion to the number of servings.  I can't figure out why this is happening.  I put in the ingredients for the full recipe which should then be divided by the servings. It seems to be multiplying everything except the actual calories those seem to be correct.  For instance I put in 8 oz of carrots it now shows 32 oz, etc.  it's the same with all the ingredients.


I just tried to analyze a chocate cookie recipe, that called for  1 bag( 12 oz) of semisweet chocalate chips or 2 cups. and the "Analyzer" would not accept neither entry, it continually said, there was an error. this is the recipe. for 48 cookies

3/4 sugar, 3/4 c brown sugar, 1 c margarine, 1 egg, 2 1/4 c plain flour, 1 tsp baking soda, 1/2 tsp salt, 2 cups semisweet chocalate chips. please give me the nutrition analyses. Thanks, MWalton

I would like to make a suggestion that "Grains" Be added as a main ingredient selection.

I just entered a new recipe without trouble. Win vista64/IE 8

I see a lot of people struggling with this, but it still seems to be doing the same.  Nobody is fixing anything.  I never had a problem with it before.  Now it stinks.  I just put something in "8 tbsp strawberry topping" for an 8 serving dessert.  It will accept the strawberry topping, but not the tbsp measurement.  No matter what I try.  It is driving me crazy.  I always liked this one before because you could copy and paste a whole recipe and not have to add each individual ingredient.  It was great!!  Now it is just a pain!

I added my recipe and all the ingredients seem to look correct after I hit analyze. How do I save it? So frustrated!

Am I not supposed to list the steps to prepare the food?

Nevermind. My browser was acting up. I refreshed and tried again and the additional instructions sections appeared. Weird.

I can't add the recipe I want either, it says "We have found 1 error in your submission". First I thought the measures were giving trouble, so I changed them. Didn't work. Then I thought the names of the ingredients weren't correct so I specified a bit. Didn't work either. Now I don't know what to do.


PS- if someone knows how to log a recipe, this is the one

I had not used the recipe feature before so can't really comment if the changes made it easier or not... I'm quite happy with the current functionality though.

A few comments / possible bugs encountered:

1. When adding a new ingredient, the title, description, instruction and other settings are erased. I managed to recover the data by going back on the web browser, but that is far from ideal

2. I have saved my recipe as "visible to others" but logging in with another account we still can't see it on the Recipe Browser (even after checking the option "use extended database"). As a workaround, if you paste the URL for the recipe directly on the web browser address it loads up fine

3. Suggestion: it would be nice to see the breakdown per ingredient and type of nutrient on the recipe. Similar to the "Full analysis" table that shows all the meals and how much each one contributed to the daily total. This way, for example, if the recipe analysis tells me that as a bad point it is high in xxx I can see the ingredients that have contributed to this and adjust accordingly.

Thank you,


Used the new Recipe Analyzer and it is working great. A lot easier to find which item to correct the ingredient and its amount. Way better than before, since I usually had to find the CC item number and add it that way. I have added four recipes in the last couple of days without any issues. Great Job.

I'm having trouble getting the serving size or amount of a custom ingredient. I have screen shots of what happens, I'll see if they work here.

Anyway, when I enter 1 serving of a custom ingredient, say 1 packet of high-protein oatmeal, the system recognizes the ingredient but not the amount. When I click on the pink drop down error box, it gives a pop-up box where it looks like you could enter the number of grams, but that doesn't work either. It just adds it again as another line, but without the ingredient. Then both lines have 0 calories in the recipe.

Am I doing something wrong here?

This won't let me paste the screen shots in here; if you can respond by a real email, I can show you what it does.


Hi I am trying to analyze a recipe on the basic page that allows me to copy and paste all of the ingredients at once.  Up until today if it did not recognize an ingredient it would give me the option of searching for it in the database but now it just shows zero calories with no opportunity to correct this.  As an example, when I type in 1/2 cup quinoa flour I get 0 calories calculated in my recipe.

I am assuming something has changed with the database and I'm doing something wrong.  Can you help?




Igor, are you out there? There seem to be many problems with using custom ingredients in the recipe analyzer.

Original Post by french_tutor:

Igor, are you out there? There seem to be many problems with using custom ingredients in the recipe analyzer.

I am out this week, but sending an email to Hal who will get in touch and work on a solution. Thanks for pinging.

Original Post by french_tutor:

Igor, are you out there? There seem to be many problems with using custom ingredients in the recipe analyzer.

Are you still having issues with this, we found and fixed a bug earlier today with custom foods and recipes. Can you try again and confirm what problem you are still seeing.

This is the most frustrating website ever! I am trying to add a recipe so I can get the calorie count, and half of the items didn't come up in the recipe when I clicked Create. Custom foods don't arent able to link to the Add to Recipe key. Even when I log meals for the day, most of the time it adds the item on twice and I have to go back and delete. There has to be a better site out there!!

I retried my recipe with custom foods, and the problem with the serving size or amount appears to have been fixed. There are still some items in the food bank that are not recognized, even when typed in exactly as they appear in the database; for instance, Organic Golden Flaxseed Meal, so I have to look up the item individually and use its unique number. But I can live with that.

The title case in the title is a little frustrating - it won't accept two capital letters in a row. For instance, I named the recipe "NL Peanut Butter-Oatmeal Cookies" but the Capital L comes out as a small l, making it look like Nl. The NL is supposed to stand for New Life. This could present a problem for many recipes that have double capital letters in the titles, like BB's Barbecue, Uncle AJ's Hot Chili, or M&M Blast.

Thanks for addressing the quantity issue. I find Calorie Count to be a very beneficial site, and I always get great response when I write in about a problem.

Is there any way you could add more things to the "Main Ingredient" drop-down box, like Oats, Grains, Soy, Tofu, Turkey (or Poultry), Cereal, Corn, Tortillas?


Quote  |  Reply

I tried to analyze a recipe over the weekend and it worked great at first but could not figure out how to save it and also I had to try to find the anaylsis for farro grain and then have it entered in the recipe.  Now when I do the same process as before, all the ingredients are highlighted in pink and it won't do an anaylysis.


247 Replies (last)